Reply to this topicStart new topic

> Please Help!, XPAI login failed
atomino01
Posted: Apr 11 2008, 05:56 PM
Quote Post


Newbie
*

Group: Members
Posts: 6
Member No.: 2873
Joined: 11-April 08



I am using Xmailserver 1.24 on SuSE 10.2 with XPAI 1.16 Frontend.
It works fine for a long time.
After a update from Apache_mod_php and PHP 5.2.0 to 5.2.5
I can not login to the XPAI frontend.
<?=$loginuser?> appers in the username field and
0)) { if (count($servers) > 1) { echo '"; } else { echo key($servers); echo ''; } } else echo 'No server configured!'; ?> on Server field.
Anything changed in PHP...?
Can anyone help me to solv the problem?
PMEmail Poster
Top
atomino01
Posted: Jun 5 2008, 03:00 PM
Quote Post


Newbie
*

Group: Members
Posts: 6
Member No.: 2873
Joined: 11-April 08



I've got no answer... smile.gif
thank you for the helpful forum
PMEmail Poster
Top
Sob
Posted: Jun 5 2008, 05:21 PM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



It looks that the php code is not executed. What about short_open_tag in php.ini? Is it set to On?
PMEmail Poster
Top
atomino01
Posted: Jun 6 2008, 09:05 AM
Quote Post


Newbie
*

Group: Members
Posts: 6
Member No.: 2873
Joined: 11-April 08



QUOTE (Sob @ Jun 5 2008, 05:21 PM)
What about short_open_tag in php.ini? Is it set to On?

Thank you Sob for helping.
short_open_tag was Off, I set it to On but it doesn't works.
In former version of PHP (5.2.0) ist works with short_open_tag = Off.
PMEmail Poster
Top
Sob
Posted: Jun 7 2008, 02:09 AM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



I don't say I don't believe you, but if I was you, I'd check it again. smile.gif

Because if you look at includes/login.php, then you'll see that both content of username and server fields are starting with "<?" and it's short open tag and I say there's no way how it could ever work with short_open_tag Off.

Try to create file phpinfo.php in the same directory where you have XPA, insert the following:

<?php
phpinfo();
?>

then open it in browser and search for short_open_tag.
PMEmail Poster
Top
atomino01
Posted: Jun 16 2008, 05:23 PM
Quote Post


Newbie
*

Group: Members
Posts: 6
Member No.: 2873
Joined: 11-April 08



QUOTE (Sob @ Jun 7 2008, 02:09 AM)
...but if I was you, I'd check it again. smile.gif


Hallo Sob,

thank you very much for your help.
When I tested it before, I did not restart the httpd.
I restart the machine and now short_open_tag works.
It means the webfrontend looks like before...
but login is not possible.
It must be another reason in the php-code...
If anyone had an idea it is welcome.
PMEmail Poster
Top
Sob
Posted: Jun 16 2008, 11:46 PM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



I'm pretty sure that the current php.ini in use is not the same as was before the update.
Try to find the original file and put it instead of the current one.
Probably some required extension is not enabled in current php.ini, or something like that..
PMEmail Poster
Top
atomino01
Posted: Sep 25 2008, 10:54 AM
Quote Post


Newbie
*

Group: Members
Posts: 6
Member No.: 2873
Joined: 11-April 08



Hallo Xpai-Users,

the failure was in the xpai config.php.
In '$servers = array' I changed "localhost"=>"localhost:6017"
with "real server name"=>"IP adress:6017".
In my case "mailserver"=>"10.250.154.253:6017".
Now it works! smile.gif
You can see the servername on the login page.
If you have some servers in the array you can choose
a server on the login page.

atomino01
greetings from germany
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | Webmail Add-ons | Next Newest »

Reply to this topicStart new topic