Reply to this topicStart new topicStart Poll

> Message Files Are Not Created And I Can't Seem To, find an error for it
ciuly
Posted: Jan 30 2010, 06:32 PM
Quote Post


Member
***

Group: Members
Posts: 62
Member No.: 1843
Joined: 29-November 05



Hello.

I just migrated my server (hw and sw) from what's in my signature (yeah, I'll update that later on) to a dual proc 866 intel PIII with 512 mb ram and 2 scsi 19GB hdd in raid (0 for swap 1 for /) and a storage ide hdd of 80 GB.
in installed centos 5, latest. when I moved my xmail files to the new machine, obviously it didn't start complaining about whatever .so so I downloaded 1.26 and rebuilt, figuring it was about high time to upgrade xmail as well.

I can send email from local network to internet. I can also receive emails up to one point: smtp.log file shows that RCPT and RECV are OK. filters and all are being processed ok.
however, no file is created in the users dir:
$MailRoot/domains/domain/user/Maildir/new

domains dir is actually a symlink to the storage hdd (that's how it used to be on the old system and it worked fine). same is the logs folder (which is being used ok since I can see the logs). everything else is where it should be.

everything is chowned to root:root (including stuff in the symlinks)

(note: I had to set and export the MAIL_ROOT for the following to work)
CODE

[root@Impuls bin]# ./XMail --debug -Md -Mr 24 -Pl -Pt 120 -Pw 5 -B- -Sl -St 120 -X- -Ql -Qg -Yl -Fl -Cl -Ct 120 -W- -Ll
SMAIL thread [00] started
SMAIL thread [01] started
SMAIL thread [02] started
SMAIL thread [03] started
SMAIL thread [04] started
SMAIL thread [05] started
SMAIL thread [06] started
SMAIL thread [07] started
SMAIL thread [08] started
SMAIL thread [09] started
SMAIL thread [10] started
SMAIL thread [11] started
SMAIL thread [12] started
SMAIL thread [13] started
SMAIL thread [14] started
SMAIL thread [15] started
[XMail 1.26 CTRL Server] started
[XMail 1.26 POP3 Server] started
[XMail 1.26 ESMTP Server] started
[XMail 1.26 PSYNC Server] started
[XMail 1.26 FINGER Server] started
LMAIL thread [00] started
LMAIL thread [01] started
LMAIL thread [02] started
SMTP client connection from [209.85.218.221]
SMTP filter run: Filter = "/var/MailRoot/filters/mydomainonly" Retcode = 1
SMTP filter run: Filter = "/var/MailRoot/filters/ensure-noreply" Retcode = 1
SMTP filter run: Filter = "/var/MailRoot/bin/sa_filter_post.pl" Retcode = 7
SMTP filter run: Filter = "/var/MailRoot/filters/rejectspam_post" Retcode = 1
SMTP filter run: Filter = "/var/MailRoot/filters/*****1" Retcode = 1
SMTP filter run: Filter = "/var/MailRoot/filters/pre-anti-bounce" Retcode = 1
SMAIL local SMTP = "ciuly.com" From = <XXX@gmail.com> To = <root@ciuly.com>
SMTP client exit [209.85.218.221]


so basically my question is: where is my email file? I did a
find /var/MailRoot/domains/ -min -15
but only the .ipconn files showed up (that's from the email client polling pop3)

am I missing something? or maybe I am doing something wrong in regards to the new version?

thanks.


--------------------
I hate looking up all this information every time I create a new topic so here goes:
I'm running XMail v 1.26 on linux centos 5 CLI-only kernel 2.6.18-194.32.1.el5 with filters.out having one filter, filters.post-data having 5 custom filters (first one SA), filters.pre-data having 2 custom filters and SA v 3.3.1 running on Perl v 5.8.8 with a weekly crontab entry for sa-update
PMUsers WebsiteYahoo
Top
ciuly
Posted: Jan 30 2010, 11:06 PM
Quote Post


Member
***

Group: Members
Posts: 62
Member No.: 1843
Joined: 29-November 05



dropping the symlink to "domains" and having it a normal dir on the local disk solved the problem.

which obviously makes me think: WHY doesn't xmail like symlinks for the domains? the logs worked and they were also symlinked to the sotrage drive like domains. why was this added?.


--------------------
I hate looking up all this information every time I create a new topic so here goes:
I'm running XMail v 1.26 on linux centos 5 CLI-only kernel 2.6.18-194.32.1.el5 with filters.out having one filter, filters.post-data having 5 custom filters (first one SA), filters.pre-data having 2 custom filters and SA v 3.3.1 running on Perl v 5.8.8 with a weekly crontab entry for sa-update
PMUsers WebsiteYahoo
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | XMail Server | Next Newest »

Reply to this topicStart new topicStart Poll