Reply to this topicStart new topicStart Poll

> Auth Problem, Can Send Without Password
Fago
Posted: Dec 13 2011, 04:16 PM
Quote Post


Newbie
*

Group: Members
Posts: 1
Member No.: 7371
Joined: 13-December 11



I've noticed that someone from the outside can log into my server and send e-mail to my xmail users without any password.

Check that:
CODE
telnet mail.mydomain.pl 25


M: Me
S: Server

CODE

S: 220 ESMTP mail.mydomain.pl
M: HELO anotherdomain.pl
S: 250 mail.mydomain.pl
M: MAIL FROM:<me@anotherdomain.pl>
S: 250 Ok
M: RCPT TO:<user@mydomain.pl>
S: 250 Ok


Settings:
EnableAuthSMTP-POP3 is set to "0"
smtprelay.tab is empty
#"SmtpConfig"[TAB]"mail-auth" is commented

Domains.tab:
mail.mydomain.pl

I saw that someone here had same problem:
http://old.nabble.com/xmail-serious-auth-p...td25985348.html

Its possible to fix that?
PMEmail Poster
Top
Sob
Posted: Dec 25 2011, 12:44 AM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



It's not bug, it's feature. There's difference between accepting mail for domains owned by server and relaying mail elsewhere. Open relay is bad thing. But accepting mail for own domains from anyone is how the whole mail system works. Other servers have no way to know any password for your server. So "fixing" this would mean no incoming mail for your users from other servers. And people usually do want to receive mail from other servers/domains. wink.gif

But if you know what you're doing, XMail can filter incoming messages. The keyword to look for in manual is filters.in.tab.
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | XMail Server | Next Newest »

Reply to this topicStart new topicStart Poll