Reply to this topicStart new topicStart Poll

> Can Send But Cannot Receive Mails
srudolf
  Posted: Jan 22 2013, 04:58 PM
Quote Post


Junior Member
**

Group: Members
Posts: 37
Member No.: 2081
Joined: 14-June 06



Hi.

Recently I changed the smtp port from 25 to 587 into my Xmail server. The users can send emails to others accounts from same domain and others domains from web (like gmail, hotmail, yahoo, etc) but after the changing of smtp port only mails from the domain into my Xmail server can be received. I have tried sending mails from my gmail and yahoo accounts to my Xmail account but it is not working! What can be wrong?

My Xmail server is installed into an Windows 2000 server and the connection from LAN to WAN is filtred with a Linux based firewall/proxy.
PMEmail Poster
Top
Sob
Posted: Jan 27 2013, 04:27 PM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



If you really changed smtp from port 25 to 587, i.e. you now have no smtp on port 25, then the answer is very easy - you broke it. smile.gif It can't work, because other servers will always try to deliver mail only to port 25.

Port 587 is not smtp, it's called submission and is for users only. It's still pretty much smtp (same commands, etc...) to make it easier for mail clients, but there's at least one difference from smtp, that it always requires authentication and as such can't be misused for anonymous spam. XMail does not really support submission, you can only put smtp on non-standard port. Which is still fine, if you need it because of often blocked port 25, it will work. But you have to keep smtp on port 25 too.

I'm just not sure if XMail supports two smtp ports or if you need to use some kind of external port forwarding.
PMEmail Poster
Top
srudolf
Posted: Jan 28 2013, 04:28 AM
Quote Post


Junior Member
**

Group: Members
Posts: 37
Member No.: 2081
Joined: 14-June 06



Thank you for your answer, Sob.

After sending the doubt here, I have found a answer. By the same way that you suggested, I just added another IP in the server where is the Xmail and I have reconfigured the Xmail server to accept two ports (25 to server-server communication and 587 to client-server comunication) using command line. Now Xmail server is working fine.
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | XMail Server | Next Newest »

Reply to this topicStart new topicStart Poll