Closed TopicStart new topicStart Poll

> Problem Sending Email Inside Network, can send mail outside network but not in
blyles
Posted: Feb 19 2013, 11:03 PM
Quote Post


Newbie
*

Group: Members
Posts: 2
Member No.: 8780
Joined: 8-February 13



hey everyone!
I'm using XMail to send validation emails for a PHP-based website. In
testing, I can send email outside our company domain, but none inside.
Here's the error message I get from the queue manager when sending inside:
ErrCode = -157
ErrString = Record not found in TAB file
Unknown user "blyles" in domain "company.com"


Ubuntu 10.04.4 LTS
xmail 1.25-4.1

Here's my server.tab (all commented lines have been
removed):
"RootDomain" "company.com"
"SmtpServerDomain" "smtp.company.com:25000"
"POP3Domain" "mail.company.com"
"HeloDomain" "company.com"
"PostMaster" "postmaster@company.com"
"ErrorsAdmin" "postmaster@company.com"
"TempErrorsAdmin" "blyles@company.com"
"DefaultSMTPGateways" "smtp.company.com:25000"
"RemoveSpoolErrors" "0"
"Pop3LogPasswd" "0"
"MaxMTAOps" "16"
"ReceivedHdrType" "0"
"FetchHdrTags" "+X-Deliver-To,+Received,To,Cc"


Here's my smtpfwd.tab:

"*" "smtp.company.com:25000"

i also have a smtp.company.com.tab file created in the userauth/smtp folder with appropriate info.

hschneider said something about the local domain needing to be named differently, which i don't understand.

thanks in advance for your help!
PMEmail Poster
Top
Sob
Posted: Feb 21 2013, 03:26 PM
Quote Post


Member
***

Group: Members
Posts: 53
Member No.: 2881
Joined: 19-April 08



If I understand it correctly, your primary server for company.com is smtp.company.com and this server is completely different machine. If so, then you really have to name local domain differently. Because as it is now, this server thinks that it handles mail for company.com. If it gets an e-mail for anything@company.com, it does not send it anywhere else, but looks for local account to deliver it to. And it seem you don't have one and even if you did, it's not what you want.

Change the domain of this server to e.g. serverhostname.company.com and then @company.com accounts won't no longer be considered local (only @serverhostname.company.com will).
PMEmail Poster
Top
blyles
Posted: Feb 21 2013, 08:37 PM
Quote Post


Newbie
*

Group: Members
Posts: 2
Member No.: 8780
Joined: 8-February 13



Thanks, Sob, for your reply. After some thinking, I realized I made some bad assumptions. I need a MTA, not a server. I installed Exim4 and things are working as I wanted.
PMEmail Poster
Top
0 User(s) are reading this topic (0 Guests and 0 Anonymous Users)
0 Members:
« Next Oldest | XMail Server | Next Newest »

Closed TopicStart new topicStart Poll